ZCar Forum banner

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
285 Posts
Discussion Starter #1
I woke up this morning and got ready to work on my dads van, replacing the timing chain, and in the middle of the day about 1-2 o-clock i looked over at my poor 280zxt and though hm..... i walked over to it and it cranked right over! I WAS like omg! I decided to push my luck and i shut it down, and started it again! Now i was even happier, my car starts and drives?!? But how i didn't even do anything to it. But somehow it runs now. Don't ask me im just happy i got my z running. Its running good but my sensor light comes on, it this my oxygen sensor? My car did have white smoke for about the first 10 minutes idleing, well it has sat for 3 months with out starting i guess i can't be too hard on it. All i have to do now it switch the title over and get insurance on it. Fix the back right tire camber and do an alignment, get a 8" k&n kone, 3" exhaust all the way back w/no muffler and a bleeder valve and i will be pulling about mid thirteens. **** my n/a 280zx kicked a 92 eclipse gs-t ass it was legit i raced him 6 times, then pulled over to talk to him. The first question he ask was "Do you have a shift kit?" I hit a third gear scratch ever time i raced him. All i did to it was gut the cat, magnaflow muffler, and no power steering belt, i raced a 99 grand prix gt and won also,it was my friend chris' car. Yeah i guess z's do respond well to mods
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top