ZCar Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
907 Posts
Discussion Starter #1
I did a tune up a couple of weeks ago and it's getting progresivly worse. Changed the fuel filter and did nothing. I also pulled the mass air sensor harness and it would idle perfect, so i replaced the MAS, but it still has the same problem. I think i have narrowed the problem the the three vac. lines coming off the intake pipe right before the throtal body, so i replaces them the best i could with spare vac. line, but the problem has seemed to gotton worse. There is one line that runs in an "s" shape to what i think is some fuel controll unit. When i play with the new line that i ran there the idle does change. What is that peice it runs too? I'. thinking that it could be bad.
Has anyone else had this problem?
 

·
Registered
Joined
·
907 Posts
Discussion Starter #3
ya i thought abou that one too. I don't think it's the CHTS, although it would SEEM that when it's warm that the prob. is less. It's just so intermintant. What about the FICD? ( fast idle controll)
 

·
Registered
Joined
·
1,991 Posts
I wasnt thinking the CHTS, If the car has an erratic loppy idle, the tps sensor/ connector could be bad. All the fast idle controller is, is a soloniod that allows a controlled air leak. If it was faulty, you would have a harder time in cold weather getting your car to warm up. It probably would'nt make the car drive bad.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top