ZCar Forum banner
Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #1 ·
My car when running creates the worst melling exhaust, smells worse than standing in a pit area of a bunch of runining race cars. Where do I start to eliminate this problem, is the fuel not burning right?
 

·
Registered
Joined
·
3 Posts
Before you get into your car take gas x. That should help the smell. If it doesn't you might want to take a shower. That sometimes helps me. Good luck
 

·
Registered
Joined
·
1,511 Posts
This is a problem alot of older Zs have
I don't know what to do to fix it but some one here
will help you
what year is your car?
 

·
Registered
Joined
·
107,695 Posts
If it smells like I think it does, my problem is similar at an idle. I had the original cat on my car which was about shot. So i took it off----And this cured nothing! Guess if I put one back on...
 

·
Registered
Joined
·
107,695 Posts
I had hollowed my cat out a couple of months ago, and it started smelling like strong exhaust and turning the back of my white car, yellow. I couldn't take the smell anymore so I had a new cat put on and it all went away.

Just an idea..
 

·
Registered
Joined
·
107,695 Posts
<b>RE: why does my car stink?</b>

A rotten egg kind of smell is usually caused by running a too rich fuel mixture and/or your cat is worn out which would generally be caused by a too rich mixture or just plain old worn out.

ZR8ED.
 

·
Registered
Joined
·
1,511 Posts
take a look around Z-Home maybe it was that place but I read some where on how to fix that its a problem that the older Zs have so take a look and hope that its a easy/chep fix
 

·
Registered
Joined
·
1,511 Posts
for some reason the html does not work right...

www.zhome.com
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #9 ·
When did they first put cats on zcars and if I got a performance exhause system suck as the ones in Motorsports or tweeks, which i doub't have cats, would I still have the same problem.
 

·
Registered
Joined
·
107,695 Posts
I replaced my exhaust system and havn't fixed the problem on my car (75 so there is no cat). I've ran anywhere between rich to lean no smell difference. Very bad going down hills. When you push the pedal a little a putt or 2 of blue exhaust spits out going down hill. I need the head rebuilt since motor has plenty of compression. Check the compression to make sure motor isn't worn. I changed octane levels and decreased it alittle. Look for evidence of burning oil. Sam 75 280z, 81 820zxt
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top