ZCar Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
Hey guys i went outside today to see if it would start, it has not started in over a month, because the power just went dead out of the blue. So my dad ans i hook his Ford f150 to the jumpers and wait a few, the car wanted to turn over but was not going. so we opened the carb covers and sprayed some engine starter like the stuff i use in my 1973 snowmobile, then turned the key again the car started right up, it had a hard time warming up but then ideled out at 2500RPM, i know thats way to high, working on trying to fix that. my question is, how come the car keeps draining power, aslo how can my altenator not work then start working again? wahts the deal, whats going on?

Also where can i get a wire harest for my 1974 260z 2+2?

Thanks James
 

·
Registered
Joined
·
87 Posts
I had this problem, tried all the hard things, but then as it turns out it was just a worn fan belt. I had tightened the thing without checking its condition, stubid me. If thats the problem, it explains why your battery isnt recharging, but also it explains why your idling at 2500, because the engine hasnt got the load of the generator to deal with.

Could be loads of other things though
 

·
Registered
Joined
·
1,713 Posts
Sounds like you got several problems.

regarding electric, advise checking out alternator/regulator/and battery as a system. One bad one can cause the other components to fail. 260 has electromechanical voltage reg which is common suspect, but get your alternator and battery tested too.

Long warm-up points to bad thermostat. High idle points to possible vacuum leak. Don't start tweaking on carbs till you're sure you got no vacuum leaks, your ignition is tip-top, and your valves are adjusted.

Goood luck!
Al
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top