ZCar Forum banner

1 - 7 of 7 Posts

·
Registered
1978 280z
Joined
·
32 Posts
Discussion Starter #1
Today was the first day I've taken my z out after some drivetrain and suspension work. When I came home I popped the hood to find 2 pools of liquid on the engine block, under the fuel rail. I soaked some of it up with a paper towel and it doesn't smell distinctly like anything in particular. Just a faint "burnt marshmallow" smell. Looking for any ideas. My main thought is that the fuel injectors are leaking. I attached a video of the pools.pooling on block (1978 280z)
 

·
Registered
Joined
·
864 Posts
Open your radiator cap - what color is your coolant? That looks like rusty coolant to me.
 

·
Super Moderator
1983 280ZX Turbo
Joined
·
1,032 Posts
If it doesn't small like anything in particular, it's not gas. The only other thing in that area is coolant. I'd check the small hoses on the engine, and run it in place while watching for leaks.
 

·
Registered
1978 280z
Joined
·
32 Posts
Discussion Starter #4
I just opened the radiator cap to find i'm ridiculously low on coolant 🤦🏽‍♂️. Not sure why I didn't think to look previously. Thanks!
 

·
Super Moderator
1983 280ZX Turbo
Joined
·
1,032 Posts
There's a small diameter coolant hose on the front end of my 280ZX that split but was hard to see. Sounds like you're on the right track.
 

·
Registered
Joined
·
864 Posts
Coolant shouldn't be that color however. I'd flush your radiator/maybe your block to get that rust out.
 

·
Registered
1978 280z
Joined
·
32 Posts
Discussion Starter #7
I flushed my radiator and poured in some of that coolant flush with distilled water, i'll be flushing it again and replacing with coolant come this winter. I agree though, there is probably some rust/gunk clogging some of my radiator.
 
1 - 7 of 7 Posts
Top