ZCar Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
532 Posts
Discussion Starter #1
82 ZXT

just rebuilt the motor about 1000 miles ago.....

by now the rings should have seated, but it still burns oil at times...


when I had the turbo out, I noticed that there was some play (left right up down) in the shaft..... I'm wondering if my turbo could be leaking oil into the intake or the exhaste...


my motor has

new rings
new valve seats
new valve guys
new valve grind
new gaskets through-out


my turbo spins up fine and it sounds fine.... but I do get the ocational blue puff behind me, especially when using engine brakes or after letting it idle for awhile and then hitting the gas.....
 

·
Registered
Joined
·
1,992 Posts
Re: Turbos: How can you tell they are on their way

sounds to me like your trubo is probably the problem...but have you done a compression test on your motor to double check it? also...there should be very little play at all in the shaft on the turbo...don't know the spec off hand but it should be in the FSM. If I were you I'd start saving up for a rebuild on the turbo...the oil seals in it are probably going out and the bearings etc...it'd be a good time to upgrade your turbo also. When you do install a new turbo makes sure you replace the oil feed line...most places won't give you a warranty on your turbo if you don't (it's not that expensive either). I'd definetly try to dig up the spec on the freeplay of the shaft and find someone with an accurate gauge to measure it with. I've known people that go a long time with a "turbo on its way" but what happens if that turbo sends pieces into your intake? imagine what it would do to your freshly built motor.
 

·
Registered
Joined
·
383 Posts
Re: Turbos: How can you tell they are on their way

most of the time when turbos go out they blow white smoke. If the turbo is the problem, the car should be blowing white smoke out the tail pipe. You said you had end play.....how much?, alot just a little? How many miles does the turbo have on it? also check you seal between the compressor housing and the exhaust housing...most of the time if its leaking there should be some oil residue on the turbo.
later
brian
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top