ZCar Forum banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
just bought the car a bit ago, the man i bought it from told me he thinks the turbo is going bad....

lets put it this way, using the timer on the radio, it takes 9 seconds to go 0-60. why?

well the engine cuts out at about 5000rpms.

the engine will rev past that, up to 6, then i shift, and im put right in boost, only to find that it cuts out again at 5 K

what do yall think? the boost guage...well the needle goes between 0 and that first notch where the red begins....not at the red, but half way there

could it be a fuel filter? i think not, cause the engine works fine above 5K, its just not boost! a really old turbo 240SX whooped me!!! :-(

also, what will taking off and plugging the POV do? make it boost more?
i know i need to break down and get an adj. boost controler, but if my turbos getting bad, theres no need to push it even harder, right?



Post Edited (Sep 12, 8:32pm)
 

·
Registered
Joined
·
3,080 Posts
Get an aftermarket boost gauge to see what it's boosting to.

There's no problem in plugging the POV, it's cheap to do and it's only function is to keep your engine from blowing up incase your wastegate fails.

Have you replaced your distributor cap and rotor? How about spark plugs and wires?

What does your timing look like?

Are both your exhuast and intake unrestricted?
 

·
Registered
Joined
·
182 Posts
Discussion Starter #3
intake silencer is off, top of intake is gone, KN replace ment filter taped down.

exhaust stock.

new wires, plugs..

dont know about rotor or cap, ill check that tomorrrow.

havent checked timing either....

what should it be at at idel?
 

·
Registered
Joined
·
3,080 Posts
it's either 15 or 20 BTDC...look under your hood, there should be a sticker there. Or look in your FSM or Haynes.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #5
gotcha...

you think that would explain the turbo cutout?
 

·
Registered
Joined
·
3,080 Posts
Stock boost gauges are extremely unreliable. See what you are boosting before you go about getting a new turbo.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #8
just changed my plugs to NGK platnuim


gapped at .44
 

·
Registered
Joined
·
257 Posts
I thought the NGK Platnuims weren't as good a swap as the stock NGK?
 

·
Registered
Joined
·
182 Posts
Discussion Starter #11
what are "normal" plugs...

also, i just installed them not 10 miles ago, and the car still runs like it did before...

also, just installed intake, pop off valve block off, and im getting a 3 inch pipe from cat back installed tomorrow with no muffler...

should sound sweet..

you think this might solve my problem?
 

·
Registered
Joined
·
182 Posts
Discussion Starter #13
just checked, they look fine....
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top