ZCar Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

· Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
I finally got my Z back together (COMPLETELY), and I smeared a little glue on the NEW paint while putting the front emblem on, what is the best way to remove it?? What is a good polishing compound , as I may just try to polish the little spot out by hand ?
 

· Registered
Joined
·
362 Posts
That's a trade secret

The best compound (easiest to use and get) to remove small smears and other common imperfections is Mequirs fine cut cleaner, it has a number 2 on the front. This is not a wax. Be sure to read the directions carefully for new paint. There are other compounds that *maybe* better but most require high speed polishing with different pads in two or three stages. Look for this product at your local auto parts house. I sound like a **** commercial!
 

· Registered
Joined
·
1,298 Posts
Re: That's a trade secret

Did the glue smear the paint? If so, then you need to polish.

But if all you have is smeared glue, you might be able to remove it using some gentle cleaners such as Wax and Grease Remover, or Mineral Spirits. A stronger cleaner would be Denatured Alcohol or Isopropyl Alcohol.

Depending on the glue you used, you might even be able to "peel" it off. Weatherstrip adhesive (either the yellow or black kind) will usually peel off after a day or two. If not, there is a remover available that shouldn't harm the paint.

Whatever you do, take your time, don't rush and be careful. You're almost there!
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top