ZCar Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
1,344 Posts
This switch has twpo cointacts that are made as the butterfly opens. The adjustment is just the placement of the switch so that this contact takes place at the right time. This switch controls the mixture between; the idle, normal, and full power states. So you want contact immediately after you depress the accelerator for normal operation, and just as you go to full power. Make sense?
 

·
Registered
Joined
·
1,344 Posts
I was not going to say anything, but I completely agree with JR on this. I just checked mine last week and it is fine after 20 years. As long as no water gets in, nothing is goign to happen to it. I just recently finished rewiring my ignition harness (replacing all fo the connectors to it). The result was incredible, about a 30% increaser in power and everything runs a lot better. I would suggest that the problem could be with the connector to it, not the switch itself.
 

·
Registered
Joined
·
1,344 Posts
Re: Question for JC

I bought 10 connectors from MSA plus the 3-pronged one from Nissan for the TPS. 6 for the injectors, 4 for sensors/devices, and the 3-pronged one for the TPS. This job was a fair bit of work. They all fit, some with difficulty. You have to solder them into the harness. I am not sure why, you jest need to make sure there is a good connection. Lots of shrinkwrap tubing. Doing it on the car is very awkward.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top