ZCar Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
One of the few remaining issues I have with my 72 240 is all the **** noise it makes, especially when I hit a bump. Now I know for a fact that some or even most of it is coming from the passenger side door, but some is coming from the rear too. I've had my mechanic look at it, but he couldn't find anything obvious (body mounts were ok). He did NOT get into taking the rear struts apart tho. One possibility is the exhaust which is not stock and does not fit properly into the channel in the underbody. As a matter of fact it rests against the underside of the rear differential, so I'm thinking that maybe when I hit a bump, the exhaust is smacking up against the rear end. As for the door, the alignment with the body is perfect, but it is loose. If I synch it up to snug it against the body, it will no longer be in alignment with the rest of the car. Also, the rubber molding looks to be in good condition. One thing I find strange is that the passenger door does have the dovetail in place, but the driver's side door (which does not make any noise) is missing the dovetail.

Any ideas on how to fix these noises?
 

·
Registered
Joined
·
193 Posts
As for the passanger door. on the lock part mounted to the frame there is a little post or bar....it should have a plastic coating or cover...this is the bar that the lock on the door actually grabs onto. If the plastic coating is gone or worn....rap some electrical tape around the bar...its actually the perfect width...until the door shuts smooth and doesn't hang (you have too much on if it hangs.) I just bought a '83zx that did the same thing until I put tape on the little post...it fills the gap on the lock...if you don't know what I'm talking about and need a pic of mine...let me know.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top