ZCar Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter #1
Hey guys! Where does the tach get its signal from? I know many cars get it from the Alternator. My problem is that the tach needle stays at 3000 rpm while running. with the car off it goes back to 0. Also, every once in awhile if I get on it I will notice the needle will move alittle from the 3000 rpm to 0 then back to 3000. I have taken the cluster out and tightened the screws in back and cleaned all of the connections, the needle also moves freely when moved by hand. Any ideas? Thanks
 

·
Registered
Joined
·
67 Posts
Discussion Starter #3
Thanks JT, do you think that something could be wrong with my CAS. I have another that I could try, I assume its either that or a wiring issue.
 

·
Registered
Joined
·
4,296 Posts
I would assume that if the engine is running/performing fine, then you have an issue with PIN 7 or the tach itself in the instrument cluster.
 

·
Registered
Joined
·
67 Posts
Discussion Starter #5
I have always had somewhat of a rough idle. I recently purchased this car off of my brother so im trying to get it all running well. I have also noticed sometimes when it is at idle the injectors have a surge of noise (a very loud tick) not the normal injector tick. It has nismo 555cc's, I dont know if that is common for these injectors or not. But it could be caused by a faulty cas I imagine, I dont know. Thanks for your input, I'm going to check into the PIN 7 theory and go from there.
 

·
Registered
Joined
·
11,803 Posts
If I had to guess I'd say the problem is in the tach or a fuse. Since the engine is running I'd say it's not a CAS issue.
 

·
Registered
Joined
·
79 Posts
Ive had this Exact same issue! i installed a used cluster from he one i brought from tt.net and turns out the tachometer was fried there is a white calibrator behind the tachometer, but ur best bet is to buy a new gauge cluster i did for about $70 and its working perfectly. I drove around for about a year and a half and fixed it last month its not the z it is the actual cluster check for burns, Yes a little speck is a burn that throws it off.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top