ZCar Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter #1
Well I was starting up my car since it rain hard all last night. When I was driving to work I noticed that I was feeling water drips on me. I just bought this car about 3 1/2 weeks ago. When I looked up water was dripping where the t-top side meets the windshield and it leaks right there. ALSO it was leaking at another weird spot do you know where the sunvisor clips on too on the driver's side? Well it was leaking there too where the screw is at!! What the heck is going on? I had this problem when I had my Z31 and now passed on to a Z32 now JUST GREAT thought I solved all my problems too!! What I did on my z31 was opened up my T top open where the gears are and tighten the screws. Does anyone have any advice? Just learning about the Z32 technology.


Also my enging light came on hooked it up to the OBD 2 scanner I bought from walmart and says P0136 which was malfunction O2 sensor the hard part is which one is it? Called nissan to get the part numbers and found out it takes 3x O2 sensors? How do I found which one is bad instead of replacing everyone?


DenZeL KnighT
 

·
Registered
Joined
·
849 Posts
SOAK the rubber in a good rubber conditioner. Normally this will swell the seal slightly and will stop minor leaks. I have to soak mine down every 6 months or so to keep it from leaking right at the front on the drivers side where the window and the t-top seam meet.

Good luck,

Glen
78 280Z
94 300ZX 2+2
 

·
Registered
Joined
·
78 Posts
Mine did the same, like midlifez said, check your drain tube, its the small hole toward the rear hatch. I used a metal coat hanger and shoved it through, it took care of the problem, also you could use a high power airhose if you have one.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top