ZCar Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter · #1 ·
I have this stupid idiot light that is located in the upper left region of the instrument cluster that has been on for a long time. The car has been running fine and performing well. The specific light reads "sensor", but which one out of the millions has gone sour. Does this specific idiot light point to a specific sensor and if so which one is it? If I replace this questionable sensor will the light automatically go out or do I have to do something else? Oh yeah did I forget to mention that this is a 81 ZXT. All help is appreciatied.
 

·
Registered
Joined
·
107,695 Posts
<b>RE: Stupid idiot light on 81 ZXT</b>

There is a yellow/green wire with bullet connector under the passenger side dash. you have to remove the lower plastic piece (the one with the light on it) and the wire should be right there. Just disconnect the wire and your light should go off.

The sensor light is activated by the odometer and cannot be reset.

hope this helps you out.
 

·
Registered
Joined
·
107,695 Posts
<b>Simple! It is a CO2 sensor!</b>

Hi.

By Nissan design after 30K miles this light goes on indicating that CO2 sensor needs to be changed. Once it is done, it will not go on ever again.

At leas according to Nissan manual.

Eugene '83ZXT
 

·
Registered
Joined
·
95 Posts
Discussion Starter · #4 ·
RE: Simple! It is a CO2 sensor!

Actually Eugene I have replaced the O2 sensor and it has less than 5000 miles on it so I do not think that this is it. I know I read Nissan's brain twizzler too and looked puzzled holding the new extra spare part of mine. Ha-Ha at least I have a Back up for the good one that is in there now.
 

·
Registered
Joined
·
107,695 Posts
RE: Simple! It is a CO2 sensor!

The light doesn't go on because the sensor is bad, it goes off when the odometer gets to a certain mileage. This is supposed to get you to periodically take your car back to the dealer, where they check/replace the sensor and turn off the light.

Since you've already replaced it just ignore the light, cover it up with electrical tape, or disconnect the wire leading to it.
 

·
Registered
Joined
·
107,695 Posts
Under the dash on the passenger's side there is a wire that can be disconnected. It is only one wire. Simply pull it apart where it connects & this will take care of your problem.

I have the same thing on my 83 280ZXT, & it is hard to get that sensor out of there without screwing up the threads or breaking it off altogether. So, good luck if you try to replace it.
 

·
Registered
Joined
·
107,695 Posts
<b>RE: Stupid idiot light on 81 ZXT</b>

I'm sure you have already tried this, but if not, just disconnect the battery for about 60 seconds and hook it back up. Have not tried this with Z car, but on most other cars, it resets the 'brain'. If there's really nothing wrong with your car to make the light go on, it should go out and stay out if you do this.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top