ZCar Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
171 Posts
Discussion Starter #1
When I bought my 72z it had a crack in the radiator. I had the radiator repained, but it would still get up to almost 250 degrees. Then today I replaced the thermostat with a 170 degree one from nissan, which helped a little. It still gets up to around 230 degrees. Both hoses seem very pressurized when it gets warm, like something may be blocking the flow, but thats just a guess. Help Please!
 

·
Registered
Joined
·
402 Posts
Are you sure that it is not an indicating problem. Get a meat thermometer and take a reading in the coolant at the top of the radiator.
 

·
Registered
Joined
·
171 Posts
Discussion Starter #3
Ya, Im sure its not my temp guage. When It gets around 240-250, the engine runs rough and even dies sometimes! Plus, it is VERY hot to the touch.
 

·
Registered
Joined
·
184 Posts
hey open the cap and let the car warm up till the thermostat opens up when it opens you should be able to see the coolet flowing in the radiator.have you checked your timing i it off to much it can make your car over heat.also if the peaple before you put some kind of sealer in the radiator it could have clogged it up. freez
 

·
Registered
Joined
·
16 Posts
1 clogged radiator
2.hose delaminated blocking flow
3.radiator fan clutch shot
4 becareful with this problem...z's are known for blowing head gaskets when this happens
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top