ZCar Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter #1
The display panel on my stereo (Hitachi KMS-3611ZW, in a '83 280ZX) is out--none of the numbers light up, or anything else. BUT, I can sometimes get it to light up by hitting it on the case with a screwdriver. It flickers then, so I assume there's a loose wire or dirty contact somewhere. All the elements (that are supposed to be on, i.e. the ones that make up whatever's displayed) come on at the same time, and light at the same intensity, so it's probably a power connection rather than a signal line. I understand this is a common problem - it happened to my friend's '81 as well. Anyone know how to fix this, what contacts to clean, etc.?
 

·
Registered
Joined
·
741 Posts
Re: Stereo display drops out on '83 280ZX (Hitachi

I think this is a Nissan issue. I owned an 82 maxima diesel and my 95 maxima both do the same thing. I have never seen a fix for this except getting a new radio. I think of it this way. my 82 had 360k miles on it and all that was wrong was the radio. I wasn't gonna complain
 

·
Registered
Joined
·
137 Posts
Re: Stereo display drops out on '83 280ZX (Hitachi

My 83 does the same thing. Plus, It doesn't seem to hold the memory when the power is turned off. It is the second radio. The first had a channel out as well. BOTH radio displays acted the same. It's ether an design problem or I have a problem in my dash wiring. I plan an autopsy on the old radio and look for trouble points. I'll post what I find...

RbM
 

·
Registered
Joined
·
571 Posts
Re: Stereo display drops out on '83 280ZX (Hitachi

The radio lighting is accomplisher by direct as well as a rudimentary fiber optic in the faceplate. What you needed is to clean the 2 bulbs in the sockets and change the bulbs since you’re down there. The bulbs are connected to a 2-foot long harness having a 2 prong connector.
The radio harness may have the markings 27937 P9700 and 15937-FKO300.
The wires are Red/blue and Black/red

Madeline Michele
Hollywood, FL
 

·
Registered
Joined
·
69 Posts
Discussion Starter #5
Re: Stereo display drops out on '83 280ZX (Hitachi

Are we talking about the same thing? This is the digital display that shows the frequency, band, and so on.
 

·
Registered
Joined
·
137 Posts
Re: Stereo display drops out on '83 280ZX (Hitachi

I THINK the lady is refering the back lighting to the radio dress panel.

Mine goes on and off and no amount of physical punishment will make it return...

RbM
 

·
Registered
Joined
·
4 Posts
Re: Stereo display drops out on '83 280ZX (Hitachi

I just bought an 83 280ZX. The radio is doing the same thing as described. I did notice that my entire dashboard flicked "out" for a second while turning on the power to the radio. Makes me wonder if the radio could wig out other componets. For example, I have had to reset the clock a few times already. If anyone figures it out, please post the answer. Where do you go to get a replacement?
 

·
Registered
Joined
·
571 Posts
Re: Stereo display drops out on '83 280ZX (Hitachi

O righty then.
What we have here is an LCD display with multiple wires soldered to it years ago.
Looks to be cold solder joints, it happens after time.
I would tap each joint with a solder gun to reestablish a good connection.
Or just get a new radio.
I have a few extras.


Madeline
 

·
Registered
Joined
·
69 Posts
Discussion Starter #9
Re: Stereo display drops out on '83 280ZX (Hitachi

Interesting...I pulled all the little connectors to remove the front panel, then couldn't find my soldering iron, so I put it back together, and it worked! The display still drops out occasionally, but now I can bring it back by tapping the front panel. It looks like a dirty connector issue.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top