ZCar Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
608 Posts
Discussion Starter #1
Oh no, not again!

Looks like another 1,000 bucks for the Z. Apparently my rack is bad, and if I should have flushed thhe power steering fluid three years ago to avoid this, brow beat me now.

Also, I'm posting this Before searching through the past posts, just so I can get some quick and up-to-date feedback. I noticed a post from this week about it, so I'll start there (don't flame broil me up)

I tried calling Coz for part info and pricing, but no answer?! This must have been a topic discussed during my broken computer hiatus, so I'll do a search...

You guys have experience with racks going bad, could it be fixed for less than the 800 I've been quoted, and any other advice?

Thanks,
Quattropop



Post Edited (Jan 21, 2:29pm)
 

·
Registered
Joined
·
311 Posts
how difficult is the install, though? I asked this earlier and didn't get the answer I was looking for.

Mine is bad too, but I don't know if I can do it myself. Can anyone tell me how hard it is to do? Harder than 60k service or easier? Which may not say much seeing as how I still haven't even done that.

On a scale of 1-10 for someone who has never done anything more that water pump, oil change, brake pads, thermostat.
 

·
Registered
Joined
·
1,911 Posts
Make sure it's the rack-they make some terrible noise and jerk when your lower hose is leaking at the connections as many do eventually. I was once told I need a rack and it was the hose. Been working fine ever since the hose was replaced.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top