ZCar Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
133 Posts
Discussion Starter #1
Tonight it was raining, so on the way home from work i stopped to do doughnuts in the school parking lot. I got the car to go around 180 degrees and that stalled and killed the engine. After 2 tries I got the engine to re-fire, but the battery warning light came on on the dash and the alternator wasnt charging. I popped the hood and the belt is still on and working. Any ideas on what may have caused this?
 

·
Registered
Joined
·
281 Posts
Id say your on the money, but if it was raining hard, i'd see what happens after things dry out. It may just be some excess moisture (maybe). Otherwise, time to get the charging system checked. Check Battery, Alternator, etc.

Good Luck!

1984 300zx T
Ported&Polished Head
17" 350Z wheels
 

·
Registered
Joined
·
112 Posts
RyGuy,

The alternator is under the engine and is susceptible to splash-up water. You said that it was raining so you might have watered down and or shorted out the alternator.
 

·
Registered
Joined
·
548 Posts
Is your battery fastened down? I had a battery jump up and short on the hood one time when I was a little too aggressive with a hump in the road.
 

·
Registered
Joined
·
133 Posts
Discussion Starter #6
well this morning i pulled the car into the driveway to look at the alternator, and the battery was at 10 volts. I was staring at the volt gauge and out of nowhere the car started charging again. I guess it was moisture.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top