ZCar Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #1 ·
Quick question. How does the speedometer and odometer work on a z31? Is it the cable off the tranny to the dash? Because mine isn't working. One time I was going about 30 and it started working a little. It read 10mph. I knew it was wrong, but I can't understand why it didn't work fully and only just a little. Is there any way to pull out the cable off the tranny and clean it a little and see if that works? Or is it when its broke its broke?

Any help would be great.
 

·
Registered
Joined
·
458 Posts
Mine doesnt work and neither does the boost gauge and compass
 

·
Registered
Joined
·
657 Posts
on the digital dash.... I belive its located in the engine compartment to the right of the cruise contron. not sure if you can clean it.... or even if you can take it apart....... but then again anything can be taken apart, its getting it back together.
 

·
Registered
Joined
·
4,279 Posts
on an analog, it runs from tranny to back side of analog cluster through the fire wall, I'm doing the swap from digi to analog, check out my second link below and you'll see pictures of that.

on the digi dash the cable runs from tranny to the speed sensor right next to the cruise control, and then it's electronic from the speed sensor to the digi cluster. if you have problems with readings it could be the speed sensor itself, or your digi cluster is just taking a sh*t
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top