ZCar Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
572 Posts
Discussion Starter #1
I know it may sound stupid, but believe it or not this plagued me for months. I've had the same hesitation when the pedal was floored and stumbling problems that some people have had and had no answer.

After I ran codes and got the A OK from the codes, I was stumped. I tried a brand new TPS, no such luck. Finally, the other day it started to hesitate really bad. Bad to the point the car was undriveable. I would start slowly as usual and go on and it would be ok, but even now it ran like crap. I popped up the hood to check the spark plug wires and saw nothing unusual.

Next thing I noticed was that there was a hole in my cone air filter. I was like "wtf!" The next day I took off the air filter and took my little magnetic fishing wire and went right down the intake and heard the "click." When I pulled out the fishing line, there was the center piece of the cone that had fell into and down the intake. If it wasn't for the screen on the AFM who knows how much worse it could've been. The center of the air filter is about 2" wide so imagine how much clogging it was doing when I floored the pedal. It would literally get sucked down the intake and stuff it.

Once I pulled that sucker out, I gave the car a nice drive around the block and it was fine. After that I gave it a really wild ride around the block and still the same result. I ran like a beaut'. I seems that the center of the air filter fell inward and worked it's way down the intake and that's why occaisionally the car would run fine and sometimes like crap. It did get progressively worse until finally it made it's way right to the AFM and permitted pretty much no airflow.

So after that I felt I had to pass that on to everyone, just as a precautionary measure if this ever happens to you. Something really simple caused a huge huge headache.
 

·
Registered
Joined
·
312 Posts
lol sounds like a nightmare.....if you were still having that problem i would have said its your gaskets.
 

·
Registered
Joined
·
572 Posts
Discussion Starter #5
No, never said anything about stock air filter, I said cone air filter. There is two kinds, the kind with the flat front and the kind that has the hole in the center. The one with the hole has a chrome tip in the middle.

It was that chrome tip that fell out and started working it's way down the intake until it finally reached the AFM. Just picture a 2" coin stuck in your 3" hose. Pretty much the mental image I get is when you drive normally, the air getting sucked in wasn't enough to lift and slap the sucker onto the screen of the AFM therefore it ran fine, but the second you floored it, the mad rush of air literally picked up the "coin" and placed it right infront of the AFM restricting the air intake by a whopping 67%.

Hence, the sh!tty driving conditions!
 

·
Registered
Joined
·
2,227 Posts
Thanks for sharing! I've been lucky so far - owned my Z for 5 years and never expierenced idle/hesitation problems thus far. Whenever there is a post like this one however I read it over in detail and sometimes save it because I am always expecting to come into some sort of idle/hestiation/loss-of-power problem as I see them so frequently on the board here.
 

·
Registered
Joined
·
572 Posts
Discussion Starter #7
Man the hesitation problem can and will drive you crazy!!!!! I just can't believe how long it carried on, over something so simple.

But I guess that's why we have these forums to pass the knowledge and experiences down.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top