ZCar Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
880 Posts
Discussion Starter #1
everything seems to work, but my shiro wont rev past 2k and it stumbles upon acceleration.. any ideas? thanks!!!!! i need to go to town tonight and my car is down, id hate to have to pull this baby out~
 

·
Registered
Joined
·
2,953 Posts
im dreding when my car starts doing that. seems AFMs fail on these cars pretty reguarly.
 

·
Registered
Joined
·
4,283 Posts
well, the only reason it seems like it fails all the time is that 8 out of 10 morons replace the bad one with another one either for a junk yard or ebay which is the same **** thing, probably bad or towards the end of it's life!!!! go to Nissan buy a new one and I will check with you in 10 years again to see if you changed your mind about them failing all the time!!!
 

·
Registered
Joined
·
880 Posts
Discussion Starter #5
im sorry, i drove my car home, installed the s-afc and when i fired it up this is what it does..
i ran the codes and am working on that right now.. i think maybe i have a bad connection on the mass airflow wires..
 

·
Registered
Joined
·
880 Posts
Discussion Starter #6
i ran the codes, and from what i found, the knock sensor doesnt get hooked up, and my input and output for the mass air flow where reversed.. its all ready to go now, just got back from the test drive.. wish i could tune it, but i need new injectors, cat, 02 and some other parts first... she's running really ruch from the injectors.. im getting black smoke on launches.. anyone know where i can get some stock/mild injectors for a good price. im going the check accel right now.. how about a good catalytic converter and 02? thanks in advance
 

·
Registered
Joined
·
2,953 Posts
I bought my high flow cat from certfified muffler for 155. bought my O2 sensor from Nissan.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top