ZCar Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
When my 76 280-z starts up it seems to be a little cold then once you start to try to drive it it warms up and it will not even think about running it starts to back fire when you give it gas and acts as if it has a running lean problem I have replaced the computer , the mass air flow , the trottle postion sensor and the fuel filter the fuel pump new plugs new wires and I am still having running problems my car will not go over 5 mph?????HELPHELPHELP.
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #3 ·
> When my 76 280-z starts up it seems to be a
> little cold then once you start to try to
> drive it it warms up and it will not even
> think about running it starts to back fire
> when you give it gas and acts as if it has a
> running lean problem I have replaced the
> computer , the mass air flow , the trottle
> postion sensor and the fuel filter the fuel
> pump new plugs new wires and I am still
> having running problems my car will not go
> over 5 mph?????HELPHELPHELP.

I'm a little confused by Phantom's request for replacing the air regulator. Does he mean the air flow meter (AFM) or air temp. sensor in the AFM? I'm experiencing similar symptoms and after reading my manuals and having done similar things to my car as you, I suspect that I may have some fuel injectors that are not working. I installed an entire new set of reconditioned injectors and based on the noise from the screwdriver, I think at least two are either stuck open or shut? I plan to start my car and pull each electrical connector one at a time while my car is idling to see if that is what is causing my problems. Good luck.
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #6 ·
> Several possibilities here.
> Strongly recommend you get a Nissan service
> manual - it will tell you exactly how to
> test different items to ensure where the
> problem is.
> I'd start first with your air regulator.
> I've been told they only are goood for about
> 80,000 miles before they start going bad. If
> it sticks in the closed position you have
> trouble starting the car cold, runs rich and
> idles very rough. If it sticks in the open
> the car starts fine but runs very lean after
> it warms up. It'll cost you about $100 from
> Nissan for a new one. Mine stuck closed. I'm
> putting a new one on this weekend.
> The thermotime switch and engine temperature
> sensor are probably not your problem here as
> they are more likely to cause your engine to
> run rich.
> You might check your fuel pressure too. It
> should maintain about 36 psi. If its bad,
> I'd cahnge the pressure regulator first and
> then go for the fuel pump.
> Anyone else with some ideas here?
> Good luck.
> Phantom

Phantom:

Can you describe the best way to clean the bullet connectors, i.e., Q-tip w/ alcohol? I've cleaned by other connections, but the bullets seem hard to do with a file, etc. Thanks.
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #8 ·
> There are two ways.
> 1) Go to auto parts store and get a can of
> electrical contacts cleaner spray, spray
> them well with it and then work the two
> halves in and out of each other several
> times - respray and repeat the process a
> couple times.
> 2) Go to auto parts store and buy some new
> connectors. Cut the old ones off &
> replace them. I did this as well as replace
> the entire pigtail and connector that goes
> to the engine temperature sensor and
> thermotime switch. They were in bad shape so
> did a total renewal.
> Phantom.

I went to start my car to do the injector thing, but it would not start. She was cranking, but just wouldn't do it. I pulled the prongs off my air regulator to take a look and found blue-green corrosion all over the prongs. I plan to replace the air regulator with a second hand one and clean the bullet connector to the water temp. sensor. It looks pretty dirty. The car was running last week. Can't wait til I debug these problems and get out in the open road. The car sat for 5 years before I woke it up in June. Thanks again for your assistance and I think I'll burn the midnight oil in the manuals. I found the original 76Z manual at my local library, so I have some great reference material to fall back on. Thank you for you assistnace and happy holidays. Carl :)
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top