ZCar Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
so i recently bought a 84 300zx, so far im really happy with my first z car. now the problem is she is running hot in traffic, idling for a long time, or going slowly up hills. the day i bought the car the heater core went on me, so i had that bypassed untill i have the cash to fix it properly. the mechanic also said that my fan clutch was gone so i got a new one of those, along with a new thermostat. i always make sure i have plenty of coolant, (there is a small leak coming from a hose or something under the fan) does anyone have any ideas as to why my car is still running hot,?? it doesnt get to the max temp, but once got to the point of bubbling and hissing when i turn it off. any input is appreciated.
also what is a good running temp idle? right now im running at 1100 - 1250 which im fairly certain is to fast
oh by the way im up in canada (vancouver bc) so it is not even that hot here yet.
thanks guys, Z on!
 

·
Registered
Joined
·
253 Posts
"there is a small leak coming from a hose or something under the fan"

Uhm, if you have a leak, that probably is a large part of the problem. Pressure doesnt build up properly, and the cooling system doesnt work as well. Look at www.az-zbum.com. It has a long list of common overheating maladies and cures.
 

·
Registered
Joined
·
657 Posts
fix that leak and buy a new cap.................. also get a coolant tester and make sure its 50/50 too much coolant is a bad thing also too little coolant is bad.......... if this doesnt fix it get your system flushed. Get ready to buy a new radiator when you do the flush.... sometimes they just burst when you flush them. also check the underside of the radiator if you have alot of bent fins than you will need a new one........good luck

also your idle should be at like 700......... i run mine at 850 because its smoother there. Do you have a Haynes manual??? if not its a good investment ($18) It will give you a bunch of good info, including how to reset your idle.



Post Edited (Jun 1, 9:41am)
 

·
Registered
Joined
·
1,839 Posts
the bad heater core is a really good indicator that the radiator is bad also. its a common problem on these 20 year old cars.
 

·
Registered
Joined
·
214 Posts
I had a bad radiator on my 86na. My symptom was running hot at highway speed though. The fan turns off when you are going fast and turns on when you are going slow.

My temp would always come down if I slowed the car down or was in town.

Replacing the rad is a big job and expensive if you pay to have it done. Labor intensive...

Maybe there is a problem with the fan.
 

·
Registered
Joined
·
919 Posts
radiator replacement

I'd always dreaded the job and tried as many other things as I could to solve my overheating problems. Now in the 5th summer I've owned the car, I finally replaced the radiator. It was a lot easier than I expected. Particularly, most of the work is done from the outside of the car and everything is pretty easy to get to. I did the whole job in about 2 and a half hours and took my time. Plus it was just $135 for a radiator that apparently exceeds the performance of the original. Now my car cools flawlessly in 100 degree heat. I still agree with fixing apparent problems and THEN troubleshooting from cheapest to most expensive, but seriously consider that your radiator could be the problem...and that's not the end of the world.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
ok then, soon as i have the time, old rad out, new one one in.! thanx for all the responses and advice
Z-on !!
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top