ZCar Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
need help,

when i back up, there is a squeaking sound coming from the rear and seems to be present when backing up only. also there is a grinding noise that occurs when going up or down an incline, it too seems to be coming from the rear also. i need some pointers of what could be the potential culprit.


1987zx NA
200k plus miles
 

·
Registered
Joined
·
958 Posts
its your breaks. I have the same issue. I'm 95% sure its your breaks. I just dont worry about it. I've got cheap breaks though.
 

·
Registered
Joined
·
548 Posts
I had two problems. One is the brakes. The other was the CV joints. I replaced both axles. Haven't got to the brakes yet but it still stops and I don't back up that much.
 

·
Registered
Joined
·
3,080 Posts
Check the tension to your E-brake. It's probably over tightened. Are your caliper slides greased up?

Does it only happen in the morning or after it's been sitting a while?
 

·
Registered
Joined
·
793 Posts
I've got both of problems, I think the sqeak is from the brakes, not sure what the grinding is though maybe it is the axles I was going to ask dspurck2 how much the axles were and how hard it was to change them and if it stoped the noises?
 

·
Registered
Joined
·
548 Posts
Ben,They were $80 each plus a $40 core each from Victoria British. I bought from them because I used to get my MG parts from them so theyy're familiar. Here's another place I've bought from. http://www.alleurasianautoparts.com
About the same price. Not a big deal to change. Follow the guidelines in the shop manuals.
Took an afternoon. I changed shocks and springs at same time. One thing I'd recommend is changing the seals in the differential while you have the axles out. They're about $20 total. No sense having to tear it all apart again later on.
Good Luck.
 

·
Registered
Joined
·
793 Posts
dspurck2--Thanks for the input, but did it stop that clicking coming from the dif area while going slow... sounds like a CV Joint but isn't..?
 

·
Registered
Joined
·
548 Posts
The clunk is gone. It was a CV joint. Two new axles solved that. I still have a squeal when I let the car roll backwards which I think is the rear brakes. Haven't gotten there yet.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top