ZCar Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
486 Posts
Discussion Starter #1
Re: Overheating 83 ZX

I changed that in the checker parking lot the other day. Compression has been fine, the engine actually is very strong, will churp from 2nd to 3rd, and smoke them in first. I hardly burns oil, very very little, this problem just occured, and it is only while at idle, not while driving hard. Any other suggestions. I checked the timing and is was fine, I did that today. Thanks for the help.
Joshua L.
 

·
Registered
Joined
·
107,695 Posts
Re: Overheating 83 ZX

> I changed that in the checker parking lot
> the other day. Compression has been fine,
> the engine actually is very strong, will
> churp from 2nd to 3rd, and smoke them in
> first. I hardly burns oil, very very little,
> this problem just occured, and it is only
> while at idle, not while driving hard. Any
> other suggestions. I checked the timing and
> is was fine, I did that today. Thanks for
> the help.
> Joshua L.

Check to see if some of your radiator tubes are plugged, and check if the fan clutch ( if thermostatically controlled) is working. When the engine is hot the fan should be very hard to turn.
Good luck!
 

·
Registered
Joined
·
486 Posts
Discussion Starter #3
Re: Overheating 83 ZX

It seems that the water is circulating, the radiator had VERY hot water in it, I stupidly took the cap off and all the water burst out, boiling hot. I know the bottom hose is not plugged because when I cahnged the water pump I got water out of the hole until the radiator was level, it seemed fine, not plugged. This has stumped me. The fan has been working fine, like I said, it is intermittant problme, days between sometimes. Also, what is the flow rate of the pump, it did not seem like it really pumped a whole lot of water very fast. Is it pretty low flow? Thanks for the help. This problem just started all of a sudden. What about rich/lean. I do not have my O2 sensor hooked up, I have a header without space for it, no accomadations? for it. Also, what about the MAF meter up front? Should I richen that then? It has been fine all summer except when it died once due to something(probably the distributor amplifier) got too hot, it ran like crap and died. It was about 105 out. Well, thanks, sorry this is so long.
Joshua L.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top