ZCar Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
re:call the tow truck..jarmo & SteveG posts

hey jarmo...yep checked and checked until I was blue in the face and everything checked "good".

steveg..yes, the info came thru you...seemed like a good deal. Mechanic at the shop reported that all injector connectors are recieving pulses...hooked up an injector they had and it worked. The injectors were DOA from NAPA, could not get it to do anything except crank. My wife picked them up and she was not given a flow sheet. At this point all I know is the injectors worked when I took them in and did not after they were "cleaned". It does seem unbelivable - all 6 at once - this is why I was stumped, I never even considered the injectors might be the problem. Well, tommorrow new rebuilt injectors are intalled and I'll just have the shop tune the Z so I can get it smogged and on the road. I have a feeling when yours were done, they knew the test requirements, the NAPA I took them to had to send the injectors to the main shop, they did not have correct attachments or something...so I think they were "cleaned" in a manner that cooked the windings.
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #2 ·
<b>RE: re:call the tow truck..jarmo & SteveG p

Just curious is NAPA going to reimburse you for th FI?
And how nuch was the cleaning service?
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #3 ·
RE: re:call the tow truck..jarmo & SteveG p

lets just say its under negotiation :) cleaning was $94.05, replacement injectors - $446, labor - $100~, towing - $43
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #4 ·
OUCH!!!!

dAD gum it! That really sucks carbon monoxide! I hope you can get your $$$ back from them, that is REALLY bad...

Best of luck

Steve
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top