ZCar Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi there I have a 84 nizzan 300zx with a turbo (which doesnt work never has) Five speed trany. Well here is the deal, when we start up the car in the morning or any time starting it up for the first time of the day the car is hard to start. When the car finnally starts it sputters and coughs when you press the accelerator the rpms drop a lot. And it takes it sometimes 15 even 20 seconds for it to catch up to its self. I have a pretty good feeling that my o2 censor is part of my problem. When your driving and you start out the car really chokes and sputers and then all of a sudden it takes off until you reach the next gear. Then it sputers and chokes again, until it reaches about 3000rpms that is about when it takes off. Some times when the car warms up to operating temp I can feel the change, from running bad to running ok. No stuttering or choking just like I remember it running before it started running bad. Some days though it runs like garbage the hole time you drive it.

Now I know that a bad o2 censor can make your car run bad but what are some signs that your fuel injectors need cleaning or ajusted? Because I dont think that its all to do with our o2 censor.

Thanks everyone for your help.
Carl
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Ok how hard is it to take the fuel injectors off of this V-6? I looked in my book and it doesnt look too hard but im not a big time macanic. How complex is it to take those fuel injectors out to clean or replace them?
 

·
Registered
Joined
·
17 Posts
I also had the same problem with sputters at low rev's trying to take off. I found it was spark wires touching the engine. The wires would arc onto the engine and make the car miss fire, but went away after 3000rpm.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top