ZCar Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
257 Posts
Discussion Starter · #1 ·
hey, i was driving 2 days ago and parked at a friends (no problems at all)
then i went outside to start it up, and it turned over pretty slowly, the battery low or something, so started driving and all of a sudden it started misfiring past 3200ish rpm then lower and lower. starting to lose some seriouis power, pulled over into a neighbor hood, it died. couldnt start back up nor even turn over. so we jump started it, it started up and ran ok. got back to my house started misfiring again, died while rolling in garage. wont start up. is this a battery or alternator problem? is this pretty easy to fix?
 

·
Registered
Joined
·
23 Posts
I had my alternator go bad an it would just shut off. it also would sqeal if you reved it up alot. it is a pain to replace. there is a plastice shield you need to take off then i thing the sway bar then work on it form the top an bottem. i might be wrong but i have delt with it on both my z's
 

·
Registered
Joined
·
880 Posts
charge the battery completely and test it. then check to make sure all electrical connections are good.. alternators are not cheap.. especailly when it is not for sure its faulty.
 

·
Registered
Joined
·
3,080 Posts
just to tell you..my battery was replaced about 1 month before I had these other problems. So it was the alternator....but yeah might as well take your battery out and get it checked, and if that's not the problem, you'll know what to replace.
 

·
Registered
Joined
·
104 Posts
get it running and take the negative battery cable off if it cuts out soon after its your alt make sure your bat is fully charged for this one. another test is to crank the car and test with a volt meter should be beetween 15 and 17 volvts good luck..id go with the maxima alt too.
 

·
Registered
Joined
·
2,227 Posts
Red - It might be different on the turbo model - but how the **** did you get the bolt on the back of the alternator off while you were in the parking lot of Autozone? hehe. I had to use a 12mm rachet from the bottom (very thin, only thing that would fit) to get that hidden bolt in the back off.

Stampy - if you have a turbo swap the Maxima Alternator in while you are at it. It is a little more difficult with the N/A because of the belt set up but it is well worth it.

- Stu85na
 

·
Registered
Joined
·
275 Posts
ive always gotten the alt out of the top, no need to get under, that one is a pain, but u can get to it , easiest and best test to ensure alt is functioning properly is, first test battery make sure ur 12.4 or so--done with car off. then start car, put lights, heat, everything on possible, and it should read like newzowner said between 15-17, if it does ur alt is working.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top