ZCar Forum banner

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
Power Windows on my 83ZX do not work. I removed the door panels and make a direct connection from the battery to test the motors. Both driver & passenger windows work fine. I removed the switch covers and sand the contact, still can't get it to work. When I checked the yellow/red wire from the switch, which I believe to be the power source; don't get any power. I know this connection is not connected to any fuse. Is there a relay involve. My AC & heat stop working also.
Can anyone help?

Thanks
 

·
Registered
Joined
·
639 Posts
Behind the rh kick panel (and then behind the wiring block) and on the other side of the metal structure is a circuit breaker/relay for the windows.

This basically takes the place of a fuse.

My windows were not working and I checked the switches, etc., much like you did. Happened to read a post here about among other things, windows not working.

I checked it out and lo and behold, when I wired the two wires direct, I got windows. One connection post on the breaker/relay was actually broken off on mine, hence no power to the motors, but they worked when connected to a live power source.

The relay/breaker attaches to the aux. fan control unit.

I got the part from Nissan (pricey for the little piece that it is -- around $40). And don't let it throw you that they list the part (number is stamped on the side of the piece) as being for the door locks, not windows. Told the parts dude that couldn't be for the door locks since mine worked when the windows didn't.

Good luck. I found it easiest to remove the wiring block. Everything is color coded on the connections, so it's pretty easy to reinstall.


Roger
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top