ZCar Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Just got an 83 turbo and she's a beauty showing 68k miles (and I believe it). I do notice that at high rpm, you can really hear a pinging noise. I've tried higher octane fuel but no help there. I put in a can of BG44k fuel treatment but have not burned the tank of gas yet.

Could it be a sensor going bad? I think it's running a little rich. Sometimes skips at idle.
 

·
Read Only
Joined
·
3,883 Posts
Re: "Pinging" when accelerating a 280ZX

good idea, and also if it were running rich, it wouldnt be pinging at high rpms unless its starving for fuel, dont qoute me cuz there are others more qualified, but im sure that pinging is a lean condition.
 

·
Registered
Joined
·
5,813 Posts
Re: "Pinging" when accelerating a 280ZX

Yea it is running lean. Set the timing to 18 degrees, the book says 20 but start there and if that is good to go then go to 20. If that doesn't fix the problem, mail me and I will send you some very detailed trouble shooting procedures to check in order to determine what the problem is.
 

·
Registered
Joined
·
361 Posts
Re: "Pinging" when accelerating a 280ZX

Also, better make sure you're not over-boosting...we KNOW that will cause it to detonate.
 

·
Registered
Joined
·
650 Posts
Re: "Pinging" when accelerating a 280ZX

You can check your plug wires and spark plug gap. I had some mild pinging and changed those and now the car runs fine.
 

·
Registered
Joined
·
168 Posts
Re: "Pinging" when accelerating a 280ZX

Don't waste your time with checking plug gaps. You either have too much timing or too much boost, if you get it without building pressure back the timing off. Also only run super in it. The only way a lean condition would be causing this is if you were on the edge of detonation to begin with and the added temp would push it that little bit further. A stock 280zxt with 7psi and your compression is for from being on the edge. A lean condition does NOT always cause detonation.
 

·
Registered
Joined
·
201 Posts
Re: "Pinging" when accelerating a 280ZX

Check to see if the wire is loose on your knock sensor. Its on the passenger side of the block between the oil filter and dipstick. If the engine pings for any reason, it tells the computer to retard the timing to a safe level. Mine was loose and it pinged BAD until I re-connected it.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top