ZCar Forum banner
Status
Not open for further replies.
1 - 1 of 1 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
First, thanks to those follow Z'ers who took the time to share their expertise regarding installation of a Crane ignition.

I did call Crane's tech line. Helpful, but they could not provide a specific answer about using a Crane ignition on my '82 280ZX turbo. They claimed I could always install the Crane system with an additional device called a universal trigger that uses the output of the factory coil to trigger the Crane system and coil. Yes this will work, but more expensive and requires additional hardware and space.

They said all the Crane system needed as a trigger is a square wave (pulse from the ECU).

The '82 ZX turbo uses an optical crank angle sensor in the distributor and sends this output to the ECU. The ECU sends a trigger pulse to the coil. It is amplified just in front of the coil by a power transistor. The ouput of that power transistor (blue lead) connects to the - side of the coil and the tachometer. The power transistor has another wire (black/white) that connects to the + side of the coil. I believe this is the +12 volts.

My question to you REAL Z tech types is this, Is the ouput of the power transistor that triggers the factory coil a square wave? If the answer is yes, than I shouldn't have any problems installing the Crane box and coil. If there is something unique or nonstanadard about this pulse, then I might have some problems. I don't have a scope so I can't check this.

Thanks again,

Chuck
[email protected]
 
1 - 1 of 1 Posts
Status
Not open for further replies.
Top