ZCar Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter #1
I just recently purchased a beautiful 73 240z. It drives wonderfully but the oil pressure gauge has me confused. The car idles at 500rpm and in stop and go traffic when I sit for awhile the oil pressure gauge drops to 0 as soon as I move and the rpm get to 1000+ it returns to normal levels. Is this a gauge thing or should I be alarmed? The temp. never moves above normal regardless of the oil gauge. Thanks for your time, Tod
 

·
Registered
Joined
·
108 Posts
> I just recently purchased a beautiful 73
> 240z. It drives wonderfully but the oil
> pressure gauge has me confused. The car
> idles at 500rpm and in stop and go traffic
> when I sit for awhile the oil pressure gauge
> drops to 0 as soon as I move and the rpm get
> to 1000+ it returns to normal levels. Is
> this a gauge thing or should I be alarmed?

Tod,

Relax.
You've just discovered the notoriously bad oil pressure sending unit that afflicts early Z's.
It does exactly as you describe.

If it really bugs you--you can get a new Nissan oil pressure sending unit that will give you the correct reading(but the thing is about $56!)

Don't get the ten dollar aftermarket jobs from your local parts superstore--it will be worse than the unit you have now!

I went that route--and ended spending the $56 anyway buying the real Nissan job.

John
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter #3
Mechanical Gauge??

Don't know if a mechanical gauge is in the cards for you, you probably want to keep the car totally stock, but if you are REALLY concerned about it, AutoMeter makes a wonderful line of gauges for all facets of engine monitoring, and I believe a 2 gauge will fit nicely in the gauge pod in the dash. Just a suggestion!

Tim

> I just recently purchased a beautiful 73
> 240z. It drives wonderfully but the oil
> pressure gauge has me confused. The car
> idles at 500rpm and in stop and go traffic
> when I sit for awhile the oil pressure gauge
> drops to 0 as soon as I move and the rpm get
> to 1000+ it returns to normal levels. Is
> this a gauge thing or should I be alarmed?
> The temp. never moves above normal
> regardless of the oil gauge. Thanks for your
> time, Tod
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top