ZCar Forum banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
217 Posts
Discussion Starter #1
The oil pressure on my 87na is reading really low lately, especially at idle, where it is almost zero. I am still getting good gas mileage and all else looks good. Are these guages prone to failure? What is the nissan part # for this guage, if I decide to replace it? Thanks............................
 

·
Registered
Joined
·
1,637 Posts
from my findings pretty much all z cars (all years excluding z33 which i dont know about) have crummy sending units. have you noticed any change in the sound of the valve train if not i would bet that its just a shitty sending unit.
 

·
Registered
Joined
·
60 Posts
LOL you didn't actually post that your z was still getting good gas mileage did you? I'm under the impression mine didn't get good mileage from the factory. Seriously though My guage has been faulty ever since I got my car. Worried about it I took it to one of the stealerships and had a tech check it out. He said that it was a common problem and that my oil pressure was fine, then offered to fix it for like $1,000,000 if I wanted.
 

·
Registered
Joined
·
217 Posts
Discussion Starter #6
How easy/hard is it to change the oil pressure guage? Does it screw out similiar to the oil filter? Anybody have a part # for it? And, I get 20 mpg in the city and about 26-27 on the hwy. That's not too bad for a car with almost a quarter million miles on it. Thanks........
 

·
Registered
Joined
·
875 Posts
don't know if they'd be the same as for my 88 turbo but:
Oil Pressure sending unit--25070-21P00
Oil Temp sending unit--25080-21P00
Try putting these numbers in www.nissanparts.cc and see if it says they are for an 87 also.

Yes the Oil Pressure unit unscrews,just to left of oil filter. either 7/16 or 9/16 I think.



Post Edited (Apr 26, 7:11am)
 

·
Registered
Joined
·
217 Posts
Discussion Starter #9
Pardon my ignorance, but where is the Oil Temp Unit located on the engine? And, where is the warning light/guage for this Oil Temp Unit? How do I know it has gone bad? Is it the red light on the dash? Thanks........
 

·
Registered
Joined
·
875 Posts
Turbos and NA's may be different, mine has a split gage that has the Oil Temp (needle type) on top and Oil Pressure on the bottom also needle type. Mine is mounted in the center of the dash next to the turbo gage.
The Oil Temp sending unit on my turbo screws directly into the passenger side of the oil pan on the side and about a foot away it plugs into the wire that goes up to the dash gage.
I replaced my Temp sending unit and it still dont work,so it could be a connection on the back of the gage. I have not gotten to that part yet. some of the guys say as long as you have oil pressure don't be concerned about the Temp. Once in a while if I hit a bump the Temp needle will work.
 

·
Registered
Joined
·
2,953 Posts
ooo thank you sansak. I need to change both those units on my SS. you saved me the trouble of having to look them up :)

as far as this guys problem goes, yes, definitly order the sending unit and change it. they fail often. and if you dont have a oil temp guage in your car you do not need the oil temp sending unit. good luck
 

·
Registered
Joined
·
875 Posts
sportdriverGT,
you are entirely welcome, i keep a list of repairs done on my car with part numbers of parts I have ordered. figured it would come in handy for someone needing them and save them a lot of search time.
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top