ZCar Forum banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
The oil pressure gauge in my 86na/analog needs to be replaced. I've heard it is better to replace it with an aftermarket than oem. If possible, I would like to put the new gauge in the same place as the old one. Is this possible, or will I need to install somewhere else on the dash?

I was looking at the oil pressure gauges (p.38) of the latest VB catalog and it says that they can install in a pod or panel but I'm not sure if they are strictly referring to the aftermarket accessory products or somewhere in the actual dash.

Suggestions, please?

Thanks...
 

·
Registered
Joined
·
94 Posts
Out of curiousity, what makes you think it needs to be replaced? It may be dead, I don't know, but it is a common problem on these cars for the oil pressure sending unit to go bad and cause the gauge to give abnormal or no readings at all. The part is cheap and its much easier than replacing the whole gauge. Might want to check that. If the gauge itself does need replacement, the link above is what you need.



Post Edited (Nov 4, 7:39am)
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
Both the oil gauge and oil light on the dash aren't working. We already replaced the sending unit but it didn't help. The guy that helps me out with my car said it would be alot easier to purchase a new gauge to hook up and install rather than try to fix the problem through the wiring.

Do you think I am doing the right thing?
 

·
Registered
Joined
·
7,924 Posts
surfzx, I'll bet you its just the oil pressure sending unit. bolts in right next to the oil filter on the side of the block. its easy and cheap to replace.
 

·
Registered
Joined
·
540 Posts
IF IT IS A DIGITAL DASH IT COULD BE THE POWER SUPPLY.B 4 U GTE A GUAGE TRY DOING A SEACH ON THE POWER SUPPLIES
 

·
Registered
Joined
·
94 Posts
phxz31 he said he already replaced it and dad7751 he already said its analog. If you replaced it and it didn't fix the problem, then I'm not sure what the problem would be. I would check the wiring out and try to fix the problem instead of buying a new gauge, but thats me and I'm a poor college kid. If its easier for you to just buy a new gauge, then go ahead. Just keep in mind that if its the wiring thats faulty, then a new gauge is not going to fix the problem. The gauge you have might be just fine.
 

·
Registered
Joined
·
80 Posts
i think i have the same problem but does your gauge work at all or does it just seem really low cuase that s what mine does. but in the morring it will read a litle over 30 but sometimes barily over 0
any advice on this prob?
 

·
Registered
Joined
·
94 Posts
As previously stated boomboom, check your oil pressure sending unit. Common problem and easy fix. I would almost guarantee thats your problem.
 

·
Registered
Joined
·
22 Posts
Hey, My oil presure meter says max and the dummy light on my dash goes on when the weather is warm. The oil pressure metre never did work but the dummy on my dash makes me wonder. Is a 97NA auto 4+4...
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top