ZCar Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
447 Posts
Discussion Starter #1
Just wondering if anyone can tell me how i'm getting what appears to be dirty oil in my intake pipes and MAS/air filter assembly. I discovered the problem when I removed the assembly so I could get to my hood latch for removal (see previous post about hood problem...). So I completely cleaned out the MAS/air filter assembly and cleaned as far as I could reach into the intake pipes. Washed everything out with soap and water. Now everything is again coated with what appears to be dirty oil again, after running the car for 5 min and taking the assembly apart again. What gives?
 

·
Registered
Joined
·
124 Posts
This happened to a friend of mine, he over oiled his cone filter. Granted you'd have to be pretty over zealous wit the oil on the filter, but just a reminder to be careful.
 

·
Registered
Joined
·
1,187 Posts
I posted about this awhile back as I found the same on mine. I was worried that it was from the turbo but I'm pretty sure it came down to being the PCV. I changed those out, got the motor in and everything is running smooth. It was a stupid design where they put it which is why many people relocate their PCV system.
 

·
Registered
Joined
·
804 Posts
So where do people relocate the pcv system to. i for one dought its the PCV's my Z has a new engine with all new vac, fuel , coolant lines, new PCV 's and hoses, Its a 93 tt 5spd. My engine only has about 1500 miles on it and I also have noticed an oil residue in the intake pipes.
 

·
Registered
Joined
·
447 Posts
Discussion Starter #7
Sorry to sound like a dumbass. I am in the process of learning about these cars as I drive it. What are the "PCV's"? And what would I have to do to relocate them?
 

·
Registered
Joined
·
777 Posts
Positive crankcase ventilation. Our Zcars have 2 and they are located (1ea) under the plenum on both sides. Do a search on how to replace PCV
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top