ZCar Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
This problem threw me for a loop because I've never had to think about this before... Anyway the Z in question is an '83ZX Turbo. The problem is that whenever I make a hard turn the inertia switch lights up the dome light and the Bitching Betty comes on and says Left door is open. - which is not the case. So I was wondering where in the world, or rather where in the car are the door sensors??? I am kinda hoping that if I can find the problem area then I can reason out what exactly is wrong, but, right now I don't have a clue as to where to begin looking.
If you know please help.
If you don't know, I'm always up for some reading about any subject you wish to bring up.
Thanks
Dave
 

·
Registered
Joined
·
10 Posts
Hey Dave I have and 82 280zx and my car also does that. The first thing you need to check is the left door switch if its pushed in the frame it then thats your problem its probably picking up a ground when you turn a corner.But if its not pushed in the frame it could be that the door flex's and makes the switch engage.

Hope this helps
Rudy
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #3 ·
> This problem threw me for a loop because
> I've never had to think about this before...
> Anyway the Z in question is an '83ZX Turbo.
> The problem is that whenever I make a hard
> turn the inertia switch lights up the dome
> light and the Bitching Betty
> comes on and says Left door is
> open. - which is not the case. So I
> was wondering where in the world, or rather
> where in the car are the door sensors??? I
> am kinda hoping that if I can find the
> problem area then I can reason out what
> exactly is wrong, but, right now I don't
> have a clue as to where to begin looking.
> If you know please help.
> If you don't know, I'm always up for some
> reading about any subject you wish to bring
> up.
> Thanks
> Dave

Dave,
It's good to know that I'm not the only one pullin' some G's in a ZXT.

The sensor is the button on the door jam that turns the light on. It's covered with a rubber boot. Maybe it's not seated correctly. But it sounds to me like you need to adjust your door latches. On the door jam, loosen the 2 big phillips screws that hold the striker plate in place. Try moving in it towards the center of the car and re-tighten. I did this to mine are boy did it take care of alot of rattles. The doors sometimes take 2 times to close, but I can live with that much better than the rattles. Good luck and let us know what happens.

Russel 83 ZXT
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top