ZCar Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
444 Posts
Discussion Starter #1
I just got my new motor started a few days ago as some of you know ... anyways, i was running it today and there is a light smoke coming out the exhaust... doesnt really smell like anything specific, just exhaust ... I am just wondering is that normal ? being that the rings havent even sealed yet cause i only have about an hour run time on it ... i will pull the plugs tomorrow to see what they look like ... any input would be great ..
 

·
Registered
Joined
·
759 Posts
what color? you prob need to check out the plugs. i have never done a full rebuild so i dont know if the smoke right after is normal or not. what motor and what mods? FI or CARB?
 

·
Registered
Joined
·
444 Posts
Discussion Starter #3
the color of the smoke is just a light blue color greyish maybe ..... its an l28 with n42 head.... .490" lift cam, flat top ross pistons, everything is new in the motor , regular fuel injection
 

·
Registered
Joined
·
4,687 Posts
My engines never smoke when first started etc but I always use nissan dealer rings. Sounds like you need to "get on it" some (75% throttle to 75% of redline) to seat the rings in.

And .490" lift cam doesn't mean much, what is the duration? That's what matters.
 

·
Registered
Joined
·
444 Posts
Discussion Starter #5
well i figured the rings just havent sealed yet ... i hope thats all it is anyways ... and its a .280 duration
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top