ZCar Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
So, originally my fuel pump wasn't working (was able to fuel up all the way without any leaks/issues). My mechanic installed a new fuel pump, then I wasn't able to fill gas past the halfway mark. Today he installed a new gasket seal for the top of the tank, tried to fill and it is still doing the same thing. It fills normally, then the pump trigger kicks off at the halfway mark, then I notice multiple drip spots of fuel under the passenger-rear side of the car, close to the rear passenger wheel. Drips for a bit, then stops. I really don't want to keep driving it around like this, going on a couple weeks. Any suggestions? Thank you!
 

·
Registered
Joined
·
368 Posts
When you say it wont fill past 1/2 way, that is according to the fuel gauge? If the gas station pump is auto stopping when filling and you cant get any more fuel in the tank, I would think that the tank is full. Why this happened when your mechanic replace an external fuel pump, IDK. Unless he thought the pump was internal (in the tank) and pulled the sending unit out and messed it up. Z fuel pumps are external. Ask your mechanic if he removed the sending unit. It sounds like he did pull the sending unit out if he had to install a new gasket on the top of the tank because it was leaking. Another case of taking an Z car to someone who knows little or nothing about the cars? Your mechanic screwed it up, he should fix it......and sending unit are no longer available and are VERY expensive used or rebuilt. Zman of Washington has someone who rebuilds them.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
My original issue with the vehicle that the fuel gage did not work, the guy who owned it told me we needed a new "Fuel Pump Assembly E8534M SP4018M FG1084", I ordered it and my mechanic installed it. Now, it reads my fuel just fine, except it leaks fuel right about at the halfway fill point of the tank, and proceeds to leak under the rear passenger wheel. He hasn't mentioned the sending unit yet, I will mention it to him. So you're thinking when he installed the new fuel pump assembly that he messed up the fuel sending unit? It's so strange that it starts to leak at the halfway fill mark, but has no issues filling up from 0-50% full mark. Any other insight would be much appreciated! Also, my mechanic is certified and they work on Nissan vehicles quite often and has worked on other cars for me in the past. Doesn't strike me as a man who doesn't have any idea about cars.
 

·
Administrator
1983 280ZX Turbo
Joined
·
2,668 Posts
Sounds like one of the vent lines on the fuel tank may be broken, allowing gas to leak out when it hits a certain level. The fuel moves around when driving and can splash out when that happens.
 

·
Registered
Joined
·
368 Posts
First off I did not say your mechanic didnt know anything about cars, I said "Another case of taking an Z car to someone who knows little or nothing about the cars?" Note the question mark. "The cars" referring to Datsun Z cars, like you have.
You may have to pull the tank to figure this out. You can use the fuel pump to remove the fuel from the tank and put it in gas cans. Remember that Z cars have really big tanks.
This part E8534M SP4018M FG1084 is for a 350z. Again the fuel pump IS NOT in your tank. that part is a sending unit with an internal pump. The only thing in the tank is the sending unit, so he had to pull the sending unit to get the fuel gauge to work the little it does now, but not to replace the pump. I'm pretty sure that the part you paid for did not go in your car. So what did he charge you for?
 

·
Registered
Joined
·
368 Posts
I read your original post again and I am confused. First you said "So, originally my fuel pump wasn't working (was able to fuel up all the way without any leaks/issues)." but after the mechanic work you stated "My mechanic installed a new fuel pump, then I wasn't able to fill gas past the halfway mark". How did you know that the tank was full or half full if the gauge didn't work?
Then you said (post #3) "My original issue with the vehicle that the fuel gage did not work, the guy who owned it told me we needed a new "Fuel Pump Assembly E8534M SP4018M FG1084", "
 
1 - 6 of 6 Posts
Top