ZCar Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I just bought a 84 300ZX, it has been sitting in a garage for like 5 years so I changed out plugs,wires, gas, and battery. I was finally able to get it running and its running rough. It idles rough and when you give it gas and it hits 2000 rpm's, the rpm's drop and it almost stalls. There is also some smoke coming out the rear, but I think that is just moisture in the engine. I was also informed by the gentleman I bought it from that there might be a problem with the turbo, but I was informed that the turbo doesn't kick in till around 3500 rpm's. Any help would be greatly appreciated.
 

·
Registered
Joined
·
1,710 Posts
i can hear my turbo start to spool around 1900-2000
 

·
Registered
Joined
·
304 Posts
it could also be the FPR... mine had similar symptoms
 

·
Registered
Joined
·
2,227 Posts
Yes - when he was saying AFM he was referring to the Mass Airflow Sensor and it is very like the cause of the 2000 RPM drop-and-stall issue that you mentioned. You can purchase and replace yourself fairly easily.

Run the ECU codes (follow guide in Haynes manual, buy if you do not have one). They will outline 1 or more problems that are probably giving you grief right now.

It is likely that your 84 just needs some maintenance and replacement of common failing parts and you will be in good shape!

Good luck!
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top