ZCar Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

· Registered
Joined
·
57 Posts
Discussion Starter · #1 ·
Well, I finally got my chearging system working. It turned out to be the voltage regulator that I got at Autozone. I ended up going to a couple of wrecking yards and pulling the original points type voltage regs and using the best one.

My first question is: What amperage does the stock Alternator put out, and is there anybody that I can buy a high output Alternator from, say 50+ AMPS? (that I can still use the external reg with)

Number 2: I put a 5-speed BW out of an 83' Turbo in my 76'. What wires coming off the tranny are for the neutral safety switch, and which are for the reverse lights? (If nothing else I will just have to do trial and error.

#3: My radiator has just started to seep. Can I pull one out of a 280ZX (looks like it would fit), or will that not work?

#4: It is getting a bit chilly, and my car doesn't like to run good until it has warmed up. I know the Cold start valve isn't working. I also know that it isn't the cold start valve's fault as I have tried four different ones. Is the thermotime switch the only possible culprite besides a bad wire or connection?

Any help is much appreciated :)
 

· Registered
Joined
·
663 Posts
Wow,
Maybe ya might want to bury it in the backyard and plant a daisy on top.
Answer to # 3. its possible, check with a motorsport or british victoria catalog and see if the parts number line up. Not 100% sure, but I thnk that 70-83 rads are interchangeable.
#4 Could be thermotime, cylinder temp sensor, air regulator.
Good job on the voltage regulator.

My 2 ¢
Ron
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top