ZCar Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
399 Posts
Discussion Starter #1
I have a 71 Z with an L28 and 72 SU round top carbs fed by a holley street pump. Heres my problem, Normal driving, putting around town she drives fine. But when I get on it it starts to sputter/flutter type sound at around 3500 RPM. If I gradually build speed it's no problem only when I get on it is when it happens. Initially I thought I may have been running the fuel pressure to low. I had it set at 2.5 so I bumped to 3.5. Same problem. I played around with the mixture settings a bit but no change. Any ideas???

Thank you
Gary
 

·
Registered
Joined
·
16 Posts
Check the oil reservoir on your SU's. They were noted for running dry.gl
1982jetblack280z wrote:
>
> Cheak your Distributor timing ( that was the problem with my
> 82, but yours is carbbed mine was EFI, but still you never
> know )
>
>
> Matt
 

·
Registered
Joined
·
327 Posts
Check your oil level in the carbs,if the problem persists try running a thicker weight oil.Personally i find 20wt silicone oil designed for R/C car shocks to be the best all around oil,but fork oil or 20wt motor oil will give good results.The springs in the domes where originaly desinged for the air flow requirerments of a L-24 so the slightly stiffer oil helps.As a last resort try one of the british parts places for stiffer springs.Here's a web page devoted to tunning SUs that has a good section about springs www.jetlink.net/~okayfine/sutech.html
 

·
Registered
Joined
·
87 Posts
I'd do what those guys above said, but when I had the same problem, it turned out just to be new plugs and leads. Its the simple things in life that matter.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top