ZCar Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
181 Posts
Discussion Starter · #1 ·
I have a '77 280z and I have a problem with the rearend making a loud banging when shifting and hitting the pettle fast when in lower gears. I have been told I have a broken mount, but I don't see any. I recall reading somwhere that it is natural for z's to do that and if it is is there any way I can minimize it?

My car runs pretty hot on a regular bases and the temp dosn't go past a certain spot, but I was wondering why it runs so hot.

My car runs pretty well most of the time, but sometimes when I start it up after I have already driven it recently it runs really rough. Is there any specific reason for it to do this.

Thanks for any help you can give me.
 

·
Registered
Joined
·
107,695 Posts
> I have a '77 280z and I have a problem with
> the rearend making a loud banging when
> shifting and hitting the pettle fast when in
> lower gears. I have been told I have a
> broken mount, but I don't see any. I recall
> reading somwhere that it is natural for z's
> to do that and if it is is there any way I
> can minimize it?

> My car runs pretty hot on a regular bases
> and the temp dosn't go past a certain spot,
> but I was wondering why it runs so hot.

> My car runs pretty well most of the time,
> but sometimes when I start it up after I
> have already driven it recently it runs
> really rough. Is there any specific reason
> for it to do this.

> Thanks for any help you can give me.

yes on the banging sound look for the broken front diff mount this can be cured by wrapping the front of the diff with strong 1/8 wire rop e (galvanized) available at any hardware store use cable clamps to keep it all tight also look for broken mustache bar mounts there is a left and a right.
the z-car thermostat and sending unit are not the most accurate in the world I would recomend getting a after market mechanical gauge.
the rough running after it gets warm could be from vapor lock on the injection manifold.try a zx manifold fan wired manually (available at most salvage yards) look for a 81,82,83 zx unit this should cure the problem.
z-ya,
the frank
 

·
Registered
Joined
·
107,695 Posts
> I have a '77 280z and I have a problem with
> the rearend making a loud banging when
> shifting and hitting the pettle fast when in
> lower gears.
I would take a good look at the limiter strap.
>is there any way I can minimize it?
Replace the limiter strap

> Thanks for any help you can give me.
Hope this helps.
 

·
Registered
Joined
·
107,695 Posts
I had the same problem on my 260Z. The studs that hold the diff to the mustache bar had backed out. We reinstalled them with locktight and the proble is gone. Hope this helps.

Rick BSPZ

> I have a '77 280z and I have a problem with
> the rearend making a loud banging when
> shifting and hitting the pettle fast when in
> lower gears. I have been told I have a
> broken mount, but I don't see any. I recall
> reading somwhere that it is natural for z's
> to do that and if it is is there any way I
> can minimize it?

> My car runs pretty hot on a regular bases
> and the temp dosn't go past a certain spot,
> but I was wondering why it runs so hot.

> My car runs pretty well most of the time,
> but sometimes when I start it up after I
> have already driven it recently it runs
> really rough. Is there any specific reason
> for it to do this.

> Thanks for any help you can give me.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top