ZCar Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
Ok, here is the scenario:

83 280ZX turbo

I have radiator fluid leaking into the floorboard on the passenger side whenever I switch my thermostat, (hot/cold) switch to cold.

It doesn't leak as long as it remains in the hot position.

I have discovered that it is leaking from a metal device under the dash. There are no leaks from any of the hoses.

What is this piece called, how to fix it, or is there anyone who knows how to by-pass it. I need my AC because of the Texas weather.

Thanks
 

·
Registered
Joined
·
190 Posts
My 80ZX does the same thing.It's ok in the heat position but dumps radiator fluid
when moved to the heat position.Hope someone has a response to this problem.
 

·
Registered
Joined
·
190 Posts
My 80ZX does the same thing.It's ok in the heat position but dumps radiator fluid
when moved to the cold position.Hope someone has a response to this problem.
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #4 ·
My '79 does the same thing but mine leaks in the hot position and is fine in the cold position. I'm sure this response means nothing to anyone, but I thought I'd through in my 2¢.
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #5 ·
It's your heater valve,the z uses coolant to power your heater and with the heat control you let the coolant in the heater core or not, change your heater valve.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top