ZCar Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
1,710 Posts
Discussion Starter #1
just did timming belt now car wonte turn over but gets all power help?? also security light flashing??

well i did the timming belt last night cam out today to start it up and check the timming and well the car will not turn over - when the key is on it gets all power radio gauges i hear the fuel pump but when i turn it to start everything just goes dead??

battery is hooked up never touched the starter?



Post Edited (Oct 11, 11:29am)
 

·
Registered
Joined
·
1,710 Posts
Discussion Starter #3
Re: just did timming belt now car wonte turn over but gets all p

ill try jumping it but amp gauge reads fine and also when the key is on start but not turning over the security light flashes?? i dont know if its supposed to do that or if thats part of my problem??

swapped batteries still same thing??



Post Edited (Oct 11, 11:39am)
 

·
Registered
Joined
·
3,080 Posts
Re: just did timming belt now car wonte turn over but gets all p

try locking and unlocking the driver's side door with the key. And then try and start it.
 

·
Registered
Joined
·
1,710 Posts
Discussion Starter #6
Re: just did timming belt now car wonte turn over but gets all p

checked all those it was something stupid got it started but timming is still way off and distriubtor is maxed out

thanks guys
 

·
Registered
Joined
·
3,080 Posts
Re: just did timming belt now car wonte turn over but gets all p

Just wondering, what was it?

Which side was is it maxxed out at?

You probably didn't put the timing belt on right; or didn't have it at TDC before you changed the belt.


*edit, eat a dick 1sikZ...lol



Post Edited (Oct 11, 5:52pm)
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top