ZCar Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
Help, my heater does not work.Well the heat part works but the blower does not work, It just stoped one day. I don't know about the heater set up in these. I was wondering if the switches go bad in these often or if any other part happens to go bad a lot. Let me know what you people think.
 

·
Registered
Joined
·
205 Posts
> Help, my heater does not work.Well the heat
> part works but the blower does not work, It
> just stoped one day. I don't know about the
> heater set up in these. I was wondering if
> the switches go bad in these often or if any
> other part happens to go bad a lot. Let me
> know what you people think.
look at the wiring under the passenger side dashboard that runs into the fan motor. i've had the connections break and the wires themselves melt. i have the original fan motor in my 71 and my 76 and they both still work, so i thing the motors themselves are fairly bullet proof.
andy [email protected]
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #4 ·
What year is your car? If it's an 82 or 83 I can probably help.

Bob A.

> Help, my heater does not work.Well the heat
> part works but the blower does not work, It
> just stoped one day. I don't know about the
> heater set up in these. I was wondering if
> the switches go bad in these often or if any
> other part happens to go bad a lot. Let me
> know what you people think.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top