ZCar Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
5,333 Posts
Discussion Starter #1
i have an '81 280zx turbo and all of the sudden the heater will quit working on me. earlier tonight it worked and i drove it, parked it for an hour and then drove it again and it still worked. then i parked it for 30 min, came back out and it quit working again. it seems to work later in the day when it has been in the sun for a while. right now it's 25 outside and it's not working. what would cause it to work in warmer weather, above freezing and to just blow cold air when it starts to get cold outside. could the antifreeze be so deluted that it can freeze and cause the switch that allows fluid into the dash to be stuck shut? it gets even colder than that here and is a major problem on drives. thanks for any info. bama
 

·
Registered
Joined
·
5,333 Posts
Discussion Starter #2
i have replaced all of the vac lines so i don't think it's those. is there some type of temp. sensor that could have gone bad? it only seems to stop working at night and early morning when it's the coldest and i need it the most. thanks again for any info, i apreciate it all. bama
 

·
Registered
Joined
·
5,716 Posts
These are all symptoms of a failing thermostat. They're like 3 bucks at any parts store, or you can get a good one from Nissan for probably double that. If it's hot where you are in the summer, get the Nissan one, as it has a larger water passage opening. Don't forget a new gasket. This simple job will keep you toasty the rest of the winter.
 
G

·
Guest
Joined
·
0 Posts
I think JR nailed this one. I would want to add that if you have doubts about your anti-freeze have it checked at an auto parts store or buy a tester. If it is weak it will cause other problems if it freezes. Good luck. john
 

·
Registered
Joined
·
5,333 Posts
Discussion Starter #5
i recently replaced the thermostat with a nissan one just like 2 months ago. i had one fron autozone and it started to fail so i bougt this one for $10. also, wouldn't i have an overheating problem if it was? the temperature gauge stays right in the middle where it always has. is there anything else that could cause this? or maybe that is it. thank you, bama
 

·
Registered
Joined
·
5,716 Posts
A good thermostat and your temp guage reads normally? Oooo, that's different. Now I'm thinking two different things: 1) your thermo-valve watchamacallit under the dash that's supposed to be letting water into the heater core is going out (common on ZXs, I've replaced two of them), or 2) your heater core and possibly engine are sludged up with gunk, all but blocking water flow. I'd tend toward the latter if this is a car that's sat for a long time. Solution: take it to a radiator shop, have 'em rod out the radiator and backflush the cooling system. You'd be surprised at what might come out.
 

·
Registered
Joined
·
5,333 Posts
Discussion Starter #7
i took it to a shop about two years ago and they flushed it out. i think the first might be right. sometimes only one of the two pipes going into the firewall gets hot, like the water was going through it. the other, onthe way out is still cold. when the heater does work then both are warm. how hard is it to replace that piece that lets water in? i need to do this soon, it's getting so cold that my 10 degree windshield washing fluid freezes when it hits the winshield. this car is my daily driver and has never sat for more than 2 weeks but i might have it flushed anyway, what could it hurt? but i think that first is right because it only works sometimes and when it does the defrost air is hot enough to cause discomfort if i hold my hand directly over it. thank you for your help.
 

·
Registered
Joined
·
5,716 Posts
I had an '82 ZXT that the heater valve was bad on when I got it. By sheer willpower, I replaced it without removing the dash. As I recall, I did this by partially disassembling the old one and putting the new "top" on it. Thisis why I had to do it a second time. It didn't hold and started dripping. The second time, I took the dash off (actually it was off for another reason) and the job was actually simple. In fact, the worst part of the whole thing was getting the dash back on.
 

·
Registered
Joined
·
5,333 Posts
Discussion Starter #9
do you know the name of the part? would i order it from nissan or just go to auto zone or some place like that? i have removed the dash a few times to replace various parts and pieces and install new speakers. where in the dash is the piece located? is it fairly easy to find or do i actually need to know what i am looking for? how much was the part? thank you for all of your help. hopefully soon i will be able to get it working again, all the time.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top