ZCar Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter · #1 ·
i got it running 'thank you all" 1980 Nissan-Datsun 280ZX 6-2753cc 2.8L SOHC (L28E) FI. 5speed.'"non-turbo'" ,"but now" black smoke comes out & rpm's a idle are at 500 very low ,we put new spark plugs "bpr6es-11 ngk" & we put it in perfect timing with a timing light.
still always at 500 rpm, & black smoke comes out.
i give a ride it. when i got back it will not start. the spark plugs became black- carbon fouling,right away , like iam getting a rich mixture of gas not burning,but why at idle is 500 this is strange.?could it be the air flow meter,idle adjusting screw ,the fuel filter-presure regulator-damper- -eec filter ,the injectors, the computer , what should i test first or do now? should i used stp fuel injector cleaner directly to the air flowmeter.

any advised are welcome.

whats this black smoke from the pipe all about.?

thank you in advanced.
[email protected]
 

·
Registered
Joined
·
107,695 Posts
RE: i got it running ,but now black smoke comes o

Check your fuel pressure, and your coolant temp switch.
It could be your brain or airflow meter, but it is usually one of the first two mentioned. Give a call if you need specs. thanks, Joe 1-800-533-5659
 

·
Registered
Joined
·
107,695 Posts
RE: i got it running ,but now black smoke come

I had that problem with my 76 280 after it sat outside without running for a few years. It was the coolant temp switch just like ALL Z EAST suggested. Blew black smoke and fouled the plugs so the engine died after about 10 miles. Took awhile to track down, I started with all the obvious, AFM, cold start valve, etc. It only cost about $35 if I remember correctly.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top