ZCar Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
4,283 Posts
Discussion Starter #1
well, I finished the LSD swap, put everything together, is was so nice watching both tires spin at the same direction, double checked everything and took it for a spin, it was Great, much noticable when shifting hard and ofcourse a little louder since I used the metal bushings from the spec shop, Drove it home from the shop and when I was almost home I started hearing some clunking coming from the rear, where, I don't know??
backed the car up on ramps, I thought the half shafts poped out, but everything was solid, halfshafts in, drive shaft was fine, so I don't know what the **** is going on!!!!

any idea's???

the diffy was New, and yes ofcourse I put oil in it, so I'm confused right now, pissed and have a sore back!!! this sucks

again, any idea's???
 

·
Registered
Joined
·
782 Posts
I would take a look at the crossmember mounts agian and go underneath the and torqe the **** out of the bolts and check you driveshaft flange mabey you forgot to tighten a couple bolts or something. It is probably something to do with the solid crossmember mounts. good luck Z's always make you work hard for more performance.
 

·
Registered
Joined
·
4,283 Posts
Discussion Starter #3
yeah I know, I went over everything and everything is fine!!! I'm lost for right now, I'll take another look tomorrow and see maybe I over looked something!!
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top