ZCar Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
there is still a humming comming from the back...what next? do i change the fuel pump now? sometimes when i start my engine i have to pump it like 6 or 7 times for the car to start...am i starving the engine? other then the humming noise i also have to leaky fuel injectors...i bought the injectors but haven't had time to change them...any connection there? please any help will be apprecitated!!!
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #2 ·
RE: I CHANGED MY FUEL FILTER BUT the sounds still

If you are talking about the fuel pump humming...they do! at least my 76 does, it means they are working. Check your fuel pressure to see if the pump is performing to spec, I don't know what the psi should be for your zx...on the 76 it is 36.3 psi. Pumping the gas pedal on a fi car does not do any good, sound more like a cold start injector not working, get your manual to trouble shoot. Take the time and replace those leaking injectors...not safe. Hope this helps,
 

·
Registered
Joined
·
567 Posts
RE: I CHANGED MY FUEL FILTER BUT the sounds still

Gary is right all z and zx fuel pumps have a hum. However, one that is going bad will whine sometimes. It sounds like something is still clogged or maybe your pump is picking up crap from the gas tank. As for those injectors, I replaced mine in an attempt to fix the problem you describe, but it didn't help. Also I'll be willing to bet the injectors aren't leaking, but the plastic bases they are mounted on are, these cost a few bucks apeice from Nissan. When you change those out you'll need to replace the o-rings in them too. I payed a little over 25 bucks to replace all 6. Hope this helps. BTW I've been down this road before, and got screwed out of alot of money if you have any more questions about my experience on this one, email me.
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #4 ·
RE: I CHANGED MY FUEL FILTER BUT the sounds still

Mine also humms a lot, and has the engine quits at idle sometimes. I am going to remove the pump and check to see if the strainer in the tank is plugged. Will let you know!
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top