ZCar Forum banner
Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #1 ·
I have a 1980 Datsun 280zx and i just finished restoring it and now it needs paint and all of the sudden it won't start. I can't find the problem

anywhere but i know what it is the car is getting way to much gas. (the spark plugs are drenched in gas) I got the car started by pinching off the

fuel line a bit but it runs eradicly and i can't find the problem anywhere!


PLEASE HELP ME


Thank you for your time


Brent ([email protected])
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #3 ·
RE: Are you getting FIRE to the plugs? Check!

i am gettin fire to the plugs because i stcuk a screwdriver in one end and held it to a ground and she zaps real good
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #6 ·
RE: Fuel pressure regualtor? 280zx

I had a similar problem with my 77. I would be suspicious of the Air Flow Meter. Disconnect the boot from the inlet side and make sure the AFM flapper is closing. Sounds like it is stuck open and telling the computer that there is wide open throttle flow and so the computer is opening the injectors and dumping more fuel. .
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #7 ·
<b>One more thing!</b>

By any chance did you rebuild the motor? Did you install the distributer and gear that drives the distributer and oil pump. If you have messed with this, then your timing is most likely off and will never start. Let me know, this is an easy fix and I can tell you what you need to do.
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #8 ·
I had a similar experience...turned out to be the CPU. It's an easy check if you can find one in a junk yard.

Mark
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #9 ·
RE: Fuel pressure Reg.

All the posts are good advise. I just added a Bell reg and piped in a temp fuel pressure guage to set the pressure. Once I got it set where I wanted, I took off the gauge and hose ( also removed the j-pipe to put on a Big-Throat: couldn't get it on, so I replaced the j-pipe) started the car and it ran like shiite. Went one mile and flooded out and wouldn't start. Waited 5 minutes, turned the key and floored the pedal. Right or wrong it started, barely, and I ran the shiite out of it home revving no lower than 3000. Got home and decreased the fuel pressure and the car starts and runs now. Still has a surging-bogging problem especially when cold, though. I recommend the pressure regulator and AFM check.
 

·
Registered
Joined
·
107,695 Posts
Discussion Starter · #10 ·
I SOLVED IT!!!

A wire got stripped and was grounding out against the frame and it fried the computer (literally!) thanx to all the people who gave me advise i really really appreciate it
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top