ZCar Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
439 Posts
Discussion Starter · #1 ·
I own a 75 280z that is getting really bad gas mileage. The car runs good and strong exept for a rough idle, but then it does have 130k on it. I just recently put a 5 speed into it from a 79 and a new cap, rotor, plugs and wires which should have upped the economy a bit over the stock crapmatic and neglected ignition suff that it had when I bought it.
 

·
Registered
Joined
·
107,695 Posts
<b>RE: HORRIBLE gas mileage!</b>

Dan, a couple of things to check first:

1. Were the plugs you removed carbon fouled? If so, you may have a cold start valve or other fuel enrichment device from the fuel injection system constantly dumping gasoline into the intake.

2. Check compression to get a sense for ring/valve leakage. If you are losing power from cylinder leakage, you have few options but to fix it or live with it till it dies.

There are many other things to check, but these are some quick ones to get a sense for where to go next.
 

·
Registered
Joined
·
439 Posts
Discussion Starter · #3 ·
The compression is within specification. So I'm not sweating an overhaul. The Original plugs were in fact carbon fouled. The air cleaner is not even a week old, and I checked the intake hoses for cracks, but none were found. If it is the cold start injector how do I make it stop wasting my gas.I'm not experinced in FI so I don't know what to look for in the way of other inrichment devices.
 

·
Registered
Joined
·
107,695 Posts
<b>RE: HORRIBLE gas mileage!</b>

Dan,

There are systematic checks you can make on all parts of the FI system. They are well addressed in the Nissan 280Z Shop Manual. If you don't have one of these, it is well worth the money - for this and other problems.

I know this isn't a clear and concise answer to your question, but the subject does not lend itself to a quick answer.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top